apache运行php5.2 5.3多个版本合集

有的时候一些程序比较挑php版本,一些稍微激进一点的程序都会对最新版本支持,如果嫌弃动手麻烦的话可以直接装个cpanel。

安装LAMP的环境配置大体流程如下

步骤一

首先必要条件安装好mysql和apache以及依赖环境包。

步骤二

安装php,5.2 5.3分开安装./configure的--prefix=路径分开指定成功编译完。

步骤三

前提说明mod_php模式有点戳上面安装php的时候记得fastcgi模式安装,如果是--with-apxs2参数安装的抱歉上去把参数调整好重新来过吧,到suphp官方下载编译安装好。

步骤四

打开suphp.conf找到类似x-httpd-php5="php:/usr/bin/php"'这么的一行代码在下面添加一行x-httpd-php53="php:/opt/php53/bin/php-cgi"

打开apache配置php的suphp段在suPHP_AddHandler x-httpd-php5下面添加suPHP_AddHandler x-httpd-php53

保存以上的配置文件然后重启httpd服务完成配置。

正常情况下apache只会运行首选的php版,在网站目录下的.htaccess里面增加一行AddHandler x-httpd-php53 .php就可以选择备选的php版本。

常规配置suphp和apache这儿略过具体的自己看着办,中间的php5.2 5.3的配置根据自己的情况可以随便配置,上述内容是以5.2为默认版本5.3为备选版本,如果你喜欢可以倒过来,如果你还喜欢可以编译安装多个其他的php版本进去。

(注释:/usr/bin/php和/opt/php53/bin/php-cgi这个路径根据自己的情况修改不用完全照里上面的写)


apache运行php5.2 5.3多个版本合集

2 条用户评论。
  1. 评论 发表时间:10-13 15:45 1楼

    做了个化妆品批发站 ecshop搭建的,想弄多个php版,实在不行 换 iis了

    1. 评论 发表时间:10-14 06:33

      需要帮忙解决类似问题的话,可以效劳。

添加新评论 »